dopo l'aggiornamento da 8 a 9 ng errore di costruzione: Importazione del simbolo inaspettato invalidFactory durante la compilazione angolare/core

voti
0

dopo aver eseguito l'aggiornamento angolare ottengo il seguente errore:

Compilazione @angular/core: modulo come errore esm5: Errore sul lavoratore #2: Errore: Importazione del simbolo inaspettato ɵɵinvalidFactory durante la compilazione @angolare/nucleo all'indirizzo Object.validateAndRewriteCoreSymbol (C:\ \siti \regent-dev \DesktopModules\DesktopModules \RegentApp_node_modules@moduli_angolari\compiler-cli \src \ngtsc \import \src\core.js:90:19)

Ho eseguito ng update @angular/cli@9 @angular/core@9 --force per aggiornare da 8 a 9 perché c'erano problemi di dipendenza da peer.

Appena fatto questo ho eseguito ng build e l'errore di cui sopra è apparso Così ho cercato di seguirlo per correggerlo

  • rollback tutte le modifiche
  • rimuovere node_modulesla cartella rm -rf node_modules
  • rimuovere il package-lock.jsonfile
  • npm i
  • npm install @angular/cli -g
  • ng update @angular/cli @angular/core --force
  • ng update --all --force

L'errore appare ancora

Qualcuno può aiutarmi a capire cosa sta succedendo?

Grazie in anticipo

Ecco l'errore che viene lanciato quando si esegue il postinstall ngcc

$ npm i

> my-app@1.3.51 postinstall C:\sites\...\App
> ngcc

Warning: Entry point '@angular/core' contains deep imports into 'C:/sites/.../node_modules/ng2-bootstrap-growl/node_modules/rxjs/symbol/observable', 'C:/sites/.../node_modules/ng2-bootstrap-growl/node_modules/rxjs/Subject', 'C:/sites/.../node_modules/ng2-bootstrap-growl/node_modules/rxjs/Observable'. This is probably not a problem, but may cause the compilation of entry points to be out of order.
Compiling @angular/core : fesm2015 as esm2015
Compiling @angular/core : main as umd
Error: Error on worker #2: Error: Importing unexpected symbol ɵɵinvalidFactory while compiling @angular/core
    at Object.validateAndRewriteCoreSymbol (C:
... Stack Trace Continues ...

la seguente è la mia versione angolare (dopo l'aggiornamento e quella che lancia l'errore):

id=pre-1
È pubblicato 25/04/2020 alle 23:13
fonte dall'utente
In altre lingue...                            

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more